9516 C++ Programming Manual: D:/9516/Cpp Directory Reference

9516 C++ Programming Manual
Cpp Directory Reference

Files

file JY9516.h
Generated by doxygen 1.9.1


9516 C++ Programming Manual: D:/9516/Cpp/JY9516.h File Reference

Typedefs | Enumerations | Functions
JY9516.h File Reference

Typedefs

typedef void * JY9516_DeviceHandle
Windows. More...

Enumerations

enum | JY9516_RefClockSource { JY9516_Onboard_10M = 0 , JY9516_PXIe_Clk_100M = 1 }
enum JY9516_AI_Range {
JY9516_Range_10V = 5 , JY9516_Range_5V = 4 , JY9516_Range_2p5V = 3 , JY9516_Range_1p25V = 2 ,
JY9516_Range_0p625V = 1 , JY9516_Range_0p3125V = 0
}
enum | JY9516_AI_Coupling { JY9516_Coupling_AC = 0 , JY9516_Coupling_DC = 1 }
enum | JY9516_AI_SampleMode { JY9516_AI_Finite = 0 , JY9516_AI_Continuous = 1 , JY9516_AI_Single = 2 }
enum | JY9516_AI_TriggerType { JY9516_AI_Immediately = 0 , JY9516_AI_Digital = 1 , JY9516_AI_Software = 2 , JY9516_AI_Analog = 3 }
enum JY9516_IOTerminal {
JY9516_External_Trigger = 0 , JY9516_PXI_Trig_0 = 1 , JY9516_PXI_Trig_1 = 2 , JY9516_PXI_Trig_2 = 3 ,
JY9516_PXI_Trig_3 = 4 , JY9516_PXI_Trig_4 = 5 , JY9516_PXI_Trig_5 = 6 , JY9516_PXI_Trig_6 = 7 ,
JY9516_PXI_Trig_7 = 8 , JY9516_PXI_Star = 9
}
enum | JY9516_DigitalTriggerEdge { JY9516_Rising = 0 , JY9516_Falling = 1 }
enum | JY9516_AnalogTriggerCondition { JY9516_RisingHysteresis = 0 , JY9516_FallingHysteresis = 1 , JY9516_EnteringWindow = 2 , JY9516_LeavingWindow = 3 }
enum | JY9516_AI_TriggerSel { JY9516_AI_Trigger_Start = 0 , JY9516_AI_Trigger_Reference = 1 , JY9516_AI_Trigger_Advance = 2 }
enum | JY9516_SyncMode { JY9516_SyncMode_Sole = 0 , JY9516_SyncMode_Master = 1 , JY9516_SyncMode_Slave = 2 }
enum JY9516_ExportSource {
JY9516_EXPORT_SAMPLE_CLOCK = 0 , JY9516_EXPORT_SYNC_ENABLE = 1 , JY9516_EXPORT_RX_READY_FOR_START_TRIG = 2 , JY9516_EXPORT_RX_START_TRIG = 3 ,
JY9516_EXPORT_RX_READY_FOR_REF_TRIG = 4 , JY9516_EXPORT_RX_REF_TRIG = 5 , JY9516_EXPORT_RX_READY_FOR_ADV_TRIG = 6 , JY9516_EXPORT_RX_ADV_TRIG = 7 ,
JY9516_EXPORT_RX_END_OF_RECORD = 8 , JY9516_EXPORT_RX_ENGINE_END = 9 , JY9516_EXPORT_MCLK = 10 , JY9516_EXPORT_DCLK = 11 ,
JY9516_EXPORT_PLL_SYNC = 12 , JY9516_EXPORT_ADC_SYNC = 13
}
enum | JY9516_CalCoePosition { JY9516_CalCoePosition_EEPROM , JY9516_CalCoePosition_Handle }
enum | JY9516_ADC_fChop_Div { JY9516_ADC_fChop_32 = 0 , JY9516_ADC_fChop_8 = 1 }
enum | JY9516_IEPEConnectionStatus { JY9516_IEPEConnection_Normal = 0 , JY9516_IEPEConnection_Open = 1 , JY9516_IEPEConnection_Short = 2 }
enum | JY9516_AI_FilterMode { JY9516_AI_FilterMode_Normal = 0 , JY9516_AI_FilterMode_WideBandwidth = 1 }

Functions

JY9516_API int | JY9516_Open (int slotNumber, JY9516_DeviceHandle *hDevice)
打开板卡 More...
JY9516_API int | JY9516_OpenByName (const char *cardName, JY9516_DeviceHandle *hDevice)
以别名打开板卡 More...
JY9516_API int | JY9516_Close (JY9516_DeviceHandle hDevice)
关闭设备，释放句柄 More...
JY9516_API int | JY9516_Init (JY9516_DeviceHandle hDevice)
初始化 More...
JY9516_API int | JY9516_GetDeviceInfo (JY9516_DeviceHandle hDevice, unsigned char *info)
获取设备信息 More...
JY9516_API int | JY9516_RouteSignalToExport (JY9516_DeviceHandle hDevice, JY9516_IOTerminal destination, JY9516_ExportSource source)
导出内部信号到指定端口 More...
JY9516_API int | JY9516_DisconnectSignalToExport (JY9516_DeviceHandle hDevice, JY9516_IOTerminal destination)
断开指定端口与内部信号的连接，复位到低电平 More...
JY9516_API int | JY9516_GetBoardTemperature (JY9516_DeviceHandle hDevice, double *temperature)
获取板卡温度 More...
JY9516_API int | JY9516_AI_EnableCalibration (JY9516_DeviceHandle hDevice, bool enabled)
获取板卡温度 More...
JY9516_API int | JY9516_AI_GetCalibrationCoefficients (JY9516_DeviceHandle hDevice, int chID, JY9516_AI_Range range, JY9516_CalCoePosition calCalSrc, bool isGolden, float *gain, float *offset)
读取指定通道设置Gain、Offset调整系数 More...
JY9516_API int | JY9516_AI_SetCalibrationCoefficients (JY9516_DeviceHandle hDevice, int chID, JY9516_AI_Range range, JY9516_CalCoePosition calCoeDest, bool isGolden, float gain, float offset)
为指定通道指定量程设置Gain、Offset调整系数 More...
JY9516_API int | JY9516_AI_EnableChannel (JY9516_DeviceHandle hDevice, unsigned int chCnt, int *chID, JY9516_AI_Range *range, JY9516_AI_Coupling *coupling, int *IEPE, int *calEnabled)
使能通道 More...
JY9516_API int | JY9516_AI_SetRefClkSrc (JY9516_DeviceHandle hDevice, JY9516_RefClockSource refClkSrc)
设置参考时钟源 More...
JY9516_API int | JY9516_AI_SetSampleRate (JY9516_DeviceHandle hDevice, double sampleRate)
设置采样率 More...
JY9516_API int | JY9516_AI_SetSamplesToAcquire (JY9516_DeviceHandle hDevice, unsigned int samplesToAcquire)
设置待采样数 More...
JY9516_API int | JY9516_AI_SetSampleMode (JY9516_DeviceHandle hDevice, JY9516_AI_SampleMode mode)
设置采样模式 More...
JY9516_API int | JY9516_AI_Commit (JY9516_DeviceHandle hDevice)
提交时钟和采样率相关配置 More...
JY9516_API int | JY9516_AI_Start (JY9516_DeviceHandle hDevice)
开始任务 More...
JY9516_API int | JY9516_AI_Stop (JY9516_DeviceHandle hDevice)
停止采集 More...
JY9516_API int | JY9516_AI_ReadSingleHeader (JY9516_DeviceHandle hDevice, int *headerBuffer)
获取所有已使能通道的转换输出标头（非缓冲式读取） More...
JY9516_API int | JY9516_AI_ReadSinglePoint (JY9516_DeviceHandle hDevice, double *dataBuffer)
获取所有已使能通道的转换输出数据（非缓冲式读取） More...
JY9516_API int | JY9516_AI_ReadRawData (JY9516_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
读取数据(原始值) More...
JY9516_API int | JY9516_AI_ReadData (JY9516_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
读取数据 More...
JY9516_API int | JY9516_AI_WaitUntilDone (JY9516_DeviceHandle hDevice, int timeout, bool *done)
检查有限点采集是否已完成 More...
JY9516_API int | JY9516_AI_CheckRxStatus (JY9516_DeviceHandle hDevice, int *rxState)
获取采集状态 More...
JY9516_API int | JY9516_AI_CheckBufferStatus (JY9516_DeviceHandle hDevice, unsigned long *availableSamplesCount, unsigned long *transferedSamplesCount, bool *overflow)
获取缓冲区状态 More...
JY9516_API int | JY9516_AI_SetStartTriggerType (JY9516_DeviceHandle hDevice, JY9516_AI_TriggerType triggerType)
设置StartTigger的触发模式 More...
JY9516_API int | JY9516_AI_SetDigitalStartTrigger (JY9516_DeviceHandle hDevice, JY9516_IOTerminal triggerSource, JY9516_DigitalTriggerEdge triggerEdge)
设置StartTrigger的数字触发源 More...
JY9516_API int | JY9516_AI_SetReferenceTriggerType (JY9516_DeviceHandle hDevice, JY9516_AI_TriggerType triggerType)
设置StartTigger的触发模式 More...
JY9516_API int | JY9516_AI_SetDigitalReferenceTrigger (JY9516_DeviceHandle hDevice, JY9516_IOTerminal triggerSource, JY9516_DigitalTriggerEdge triggerEdge)
设置ReferenceTrigger的数字触发源 More...
JY9516_API int | JY9516_AI_SetAdvanceTriggerType (JY9516_DeviceHandle hDevice, JY9516_AI_TriggerType triggerType)
设置AdvanceTrigger的触发模式 More...
JY9516_API int | JY9516_AI_SetDigitalAdvanceTrigger (JY9516_DeviceHandle hDevice, JY9516_IOTerminal triggerSource, JY9516_DigitalTriggerEdge triggerEdge)
设置AdvanceTrigger的数字触发源 More...
JY9516_API int | JY9516_AI_SetAnalogTrigger (JY9516_DeviceHandle hDevice, unsigned int triggerSource, JY9516_AnalogTriggerCondition triggerCondition, double highThreshold, double lowThreshold)
设置模拟触发 More...
JY9516_API int | JY9516_AI_SetPreTriggerSamples (JY9516_DeviceHandle hDevice, unsigned int preTriggerSamples)
设置预触发点数 More...
JY9516_API int | JY9516_AI_SetReTriggerCount (JY9516_DeviceHandle hDevice, int reTriggerCount)
设置重触发次数 More...
JY9516_API int | JY9516_AI_SendSoftwareTrigger (JY9516_DeviceHandle hDevice, JY9516_AI_TriggerSel triggerSel)
发送软件触发 More...
JY9516_API int | JY9516_AI_ConfigSync (JY9516_DeviceHandle hDevice, JY9516_SyncMode syncMode, JY9516_IOTerminal syncRequestRouting)
配置多卡同步 More...
JY9516_API int | JY9516_AI_Sync (JY9516_DeviceHandle hDevice)
启动同步。当同步模式为Sole时，立即同步PLL和ADC，不输出同步请求；当同步模式为Master时，立即同步PLL和ADC，并输出同步请求；当同步模式为Slave时，等待同步请求到达后同步PLL和ADC。应先开启Slave的同步流程，再开启Master的同步流程。 More...
JY9516_API int | JY9516_AI_SetPLLSyncDelay (JY9516_DeviceHandle hDevice, int tapCnt)
设置PLL Sync信号的输出延迟，用于精准调节PLL Sync与PLL OSCin的时序关系。 More...
JY9516_API int | JY9516_AI_CheckSyncStatus (JY9516_DeviceHandle hDevice, bool *pllSynchronized, bool *adcSynchronized)
获取同步状态 More...
JY9516_API int | JY9516_AI_GetCurrentClkFreq (JY9516_DeviceHandle hDevice, double *mclkFreq, double *fMod, double *dclkFreq)
获取当前状态下的各个时钟的频率，至少Arm()一次后才有效 More...
JY9516_API int | JY9516_AI_ParseSampleRate (double sampleRate, JY9516_AI_FilterMode filterMode, double *mclkFreq, double *fMod, double *dclkFreq, int *adcDec, int *fpgaDec, int *filterType, bool *fpgaSinc5Enabled, double *groupDelay)
获取指定采样率下的各个时钟的频率 More...
JY9516_API int | JY9516_AI_SetCalibrationInfo (JY9516_DeviceHandle hDevice, bool isGolden, short timestamp, double temperature, short coefficientsSizeInBytes, unsigned short coefficientsCRC16, float sampleRate)
写AI校准信息到EEPROM More...
JY9516_API int | JY9516_AI_GetCalibrationInfo (JY9516_DeviceHandle hDevice, bool isGolden, short *timestamp, double *temperature, short *coefficientsSizeInBytes, unsigned short *coefficientsCRC16, float *sampleRate)
从EEPROM读AI校准信息 More...
JY9516_API int | JY9516_CalCRC16 (char *data, unsigned int dataLen, unsigned short *CRC16)
计算CRC16 More...
JY9516_API int | JY9516_AI_ClearCalibrationCoefficientsValidFlag (JY9516_DeviceHandle hDevice)
清除所有校准系数有效标记，使下次开始任务时总是会从EEPROM更新校准系数 More...
JY9516_API int | JY9516_DAC_SetPowerDown (JY9516_DeviceHandle hDevice, bool powerDown)
设置DAC电源状态 More...
JY9516_API int | JY9516_DAC_SetOutputVoltage (JY9516_DeviceHandle hDevice, double voltage)
获取DAC电源状态(2022.11.01 实际调试情况发现该寄存器读取回来的值不能正确反应Power状态，即使PowerDown了也显示为PowerUp) More...
JY9516_API int | JY9516_DAC_ClearCalibrationCoefficientsValidFlag (JY9516_DeviceHandle hDevice)
清除DAC校准系数有效标记，使下次开始任务时总是会从EEPROM更新校准系数 More...
JY9516_API int | JY9516_DAC_GetCalibrationCoefficients (JY9516_DeviceHandle hDevice, JY9516_CalCoePosition calCalSrc, float *gain, float *offset)
获取DAC的Gain、Offset调整系数 More...
JY9516_API int | JY9516_DAC_SetCalibrationCoefficients (JY9516_DeviceHandle hDevice, JY9516_CalCoePosition calCoeDest, float gain, float offset)
为DAC设置Gain、Offset调整系数 More...
JY9516_API int | JY9516_DAC_SetCalibrationInfo (JY9516_DeviceHandle hDevice, short timestamp, double temperature, short coefficientsSizeInBytes, unsigned short coefficientsCRC16)
写DAC校准信息到EEPROM More...
JY9516_API int | JY9516_DAC_GetCalibrationInfo (JY9516_DeviceHandle hDevice, short *timestamp, double *temperature, short *coefficientsSizeInBytes, unsigned short *coefficientsCRC16)
从EEPROM读DAC校准信息 More...
JY9516_API int | JY9516_DAC_IssueTemperatureRecalibration (JY9516_DeviceHandle hDevice, int timeout, bool *done)
启动DAC温漂校准流程 More...
JY9516_API int | JY9516_WriteAD7768Reg (JY9516_DeviceHandle hDevice, int chipID, int regAddr, int value)
直接向AD7768指定地址写入数据 More...
JY9516_API int | JY9516_ReadAD7768Reg (JY9516_DeviceHandle hDevice, int chipID, int regAddr, int *value)
直接从AD7768指定地址读出数据 More...
JY9516_API int | JY9516_ResetAD7768 (JY9516_DeviceHandle hDevice)
产生一个硬件复位信号，复位两片AD7768 More...
JY9516_API int | JY9516_SetAD7768FChop (JY9516_DeviceHandle hDevice, JY9516_ADC_fChop_Div fchopDiv)
设置ADC调制器斩波频率 More...
JY9516_API int | JY9516_AI_DetectIEPEConnection (JY9516_DeviceHandle hDevice, JY9516_IEPEConnectionStatus *buf)
检测IEPE连接状态（正常/开路/短路）。当采集任务正在运行时不要调用；执行本操作前无需调用Commit(),但执行过本操作后若要执行采集任务则必须重新调用Commit()。 More...
JY9516_API int | JY9516_AI_SetBesselComp (JY9516_DeviceHandle hDevice, bool enable)
设置Bessel滤波器造成的通带衰减的补偿 More...
JY9516_API int | JY9516_AI_SetFilterMode (JY9516_DeviceHandle hDevice, JY9516_AI_FilterMode filterMode)
设置调制模式 More...
JY9516_API int | JY9516_AI_GetCalibrationData (JY9516_DeviceHandle hDevice, JY9516_AI_Range range, bool isGolden, unsigned char *data)
获取指定量程下所有通道的未解析的校准数据。该API用于实现校准数据拷贝 More...
JY9516_API int | JY9516_AI_SetCalibrationData (JY9516_DeviceHandle hDevice, JY9516_AI_Range range, bool isGolden, unsigned char *data)
写入指定量程下所有通道的未解析的校准数据。该API用于实现校准数据拷贝 More...
JY9516_API int | JY9516_AI_GetFilterState (JY9516_DeviceHandle hDevice, bool *filterSettled)
获取滤波器建立标志。每当ADC被复位后，该标志会被复位为0，直到滤波器重新建立。 More...
JY9516_API int | JY9516_AI_WaitUntilFilterSettled (JY9516_DeviceHandle hDevice, int timeout, bool *filterSettled)
等待直到滤波器完成建立 More...

Typedef Documentation

◆ JY9516_DeviceHandle

typedef void* JY9516_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY9516_ADC_fChop_Div

enum JY9516_ADC_fChop_Div
Enumerator
JY9516_ADC_fChop_32
JY9516_ADC_fChop_8

◆ JY9516_AI_Coupling

enum JY9516_AI_Coupling
Enumerator
JY9516_Coupling_AC
JY9516_Coupling_DC

◆ JY9516_AI_FilterMode

enum JY9516_AI_FilterMode
Enumerator
JY9516_AI_FilterMode_Normal | Normal Mode. It has 0.4Fs bandwidth, medium latency, and a maximum sample rate of 256kSa/s
JY9516_AI_FilterMode_WideBandwidth | Wide Bandwidth Mode. It has 0.4535Fs bandwidth, high latency, and a maximum sample rate of 128kSa/s

◆ JY9516_AI_Range

enum JY9516_AI_Range
Enumerator
JY9516_Range_10V
JY9516_Range_5V
JY9516_Range_2p5V
JY9516_Range_1p25V
JY9516_Range_0p625V
JY9516_Range_0p3125V

◆ JY9516_AI_SampleMode

enum JY9516_AI_SampleMode
Enumerator
JY9516_AI_Finite
JY9516_AI_Continuous
JY9516_AI_Single

◆ JY9516_AI_TriggerSel

enum JY9516_AI_TriggerSel
Enumerator
JY9516_AI_Trigger_Start
JY9516_AI_Trigger_Reference
JY9516_AI_Trigger_Advance

◆ JY9516_AI_TriggerType

enum JY9516_AI_TriggerType
Enumerator
JY9516_AI_Immediately
JY9516_AI_Digital
JY9516_AI_Software
JY9516_AI_Analog

◆ JY9516_AnalogTriggerCondition

enum JY9516_AnalogTriggerCondition
Enumerator
JY9516_RisingHysteresis
JY9516_FallingHysteresis
JY9516_EnteringWindow
JY9516_LeavingWindow

◆ JY9516_CalCoePosition

enum JY9516_CalCoePosition
Enumerator
JY9516_CalCoePosition_EEPROM
JY9516_CalCoePosition_Handle

◆ JY9516_DigitalTriggerEdge

enum JY9516_DigitalTriggerEdge
Enumerator
JY9516_Rising
JY9516_Falling

◆ JY9516_ExportSource

enum JY9516_ExportSource
Enumerator
JY9516_EXPORT_SAMPLE_CLOCK
JY9516_EXPORT_SYNC_ENABLE
JY9516_EXPORT_RX_READY_FOR_START_TRIG
JY9516_EXPORT_RX_START_TRIG
JY9516_EXPORT_RX_READY_FOR_REF_TRIG
JY9516_EXPORT_RX_REF_TRIG
JY9516_EXPORT_RX_READY_FOR_ADV_TRIG
JY9516_EXPORT_RX_ADV_TRIG
JY9516_EXPORT_RX_END_OF_RECORD
JY9516_EXPORT_RX_ENGINE_END
JY9516_EXPORT_MCLK
JY9516_EXPORT_DCLK
JY9516_EXPORT_PLL_SYNC
JY9516_EXPORT_ADC_SYNC

◆ JY9516_IEPEConnectionStatus

enum JY9516_IEPEConnectionStatus
Enumerator
JY9516_IEPEConnection_Normal
JY9516_IEPEConnection_Open
JY9516_IEPEConnection_Short

◆ JY9516_IOTerminal

enum JY9516_IOTerminal
Enumerator
JY9516_External_Trigger
JY9516_PXI_Trig_0
JY9516_PXI_Trig_1
JY9516_PXI_Trig_2
JY9516_PXI_Trig_3
JY9516_PXI_Trig_4
JY9516_PXI_Trig_5
JY9516_PXI_Trig_6
JY9516_PXI_Trig_7
JY9516_PXI_Star

◆ JY9516_RefClockSource

enum JY9516_RefClockSource
Enumerator
JY9516_Onboard_10M
JY9516_PXIe_Clk_100M

◆ JY9516_SyncMode

enum JY9516_SyncMode
Enumerator
JY9516_SyncMode_Sole
JY9516_SyncMode_Master
JY9516_SyncMode_Slave

Function Documentation

◆ JY9516_AI_CheckBufferStatus()

JY9516_API int JY9516_AI_CheckBufferStatus | ( | JY9516_DeviceHandle | hDevice,
 |  | unsigned long * | availableSamplesCount,
 |  | unsigned long * | transferedSamplesCount,
 |  | bool * | overflow
 | ) |  |

获取缓冲区状态

Parameters
hDevice | 板卡句柄
availableSamplesCount | 缓冲区已有的Sample的数量
overflow | 是否发生溢出
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_CheckRxStatus()

JY9516_API int JY9516_AI_CheckRxStatus | ( | JY9516_DeviceHandle | hDevice,
 |  | int * | rxState
 | ) |  |

获取采集状态

Parameters
hDevice | 板卡句柄
rxState | 返回有当前采集状态(RX_ENGINE_IDLE = 1,RX_ENGINE_WAIT_FOR_START = 2,RX_ENGINE_PRESAMPLE = 4,RX_ENGINE_WAIT_FOR_REF_TRIGGER = 8,RX_ENGINE_POST_SAMPLE = 16,RX_ENGINE_RECORD_COMPLETE = 32,RX_ENGINE_WAIT_FOR_ADVANCE_TRIGGER = 64,RX_ENGINE_DONE = 128)
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_CheckSyncStatus()

JY9516_API int JY9516_AI_CheckSyncStatus | ( | JY9516_DeviceHandle | hDevice,
 |  | bool * | pllSynchronized,
 |  | bool * | adcSynchronized
 | ) |  |

获取同步状态

Parameters
hDevice | 板卡句柄
pllSynchronized | PLL已同步
adcSynchronized | ADC已同步
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_ClearCalibrationCoefficientsValidFlag()

JY9516_API int JY9516_AI_ClearCalibrationCoefficientsValidFlag ( JY9516_DeviceHandle hDevice )

清除所有校准系数有效标记，使下次开始任务时总是会从EEPROM更新校准系数

Parameters
hDevice 板卡句柄
Returns
成功：0 , 失败：!=0

◆ JY9516_AI_Commit()

JY9516_API int JY9516_AI_Commit ( JY9516_DeviceHandle hDevice )

提交时钟和采样率相关配置

Parameters
hDevice 板卡句柄
Returns
成功：0 , 失败：!=0

◆ JY9516_AI_ConfigSync()

JY9516_API int JY9516_AI_ConfigSync | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_SyncMode | syncMode,
 |  | JY9516_IOTerminal | syncRequestRouting
 | ) |  |

配置多卡同步

Parameters
hDevice | 板卡句柄
syncMode | 同步模式
syncRequestRouting | 同步请求路由路径
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_DetectIEPEConnection()

JY9516_API int JY9516_AI_DetectIEPEConnection | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_IEPEConnectionStatus * | buf
 | ) |  |

检测IEPE连接状态（正常/开路/短路）。当采集任务正在运行时不要调用；执行本操作前无需调用Commit(),但执行过本操作后若要执行采集任务则必须重新调用Commit()。

Parameters
hDevice | 板卡句柄
buf | 返回各通道的IEPE开路/短路检测结果

◆ JY9516_AI_EnableCalibration()

JY9516_API int JY9516_AI_EnableCalibration | ( | JY9516_DeviceHandle | hDevice,
 |  | bool | enabled
 | ) |  |

获取板卡温度

Parameters
hDevice | 板卡句柄
enabled | 是否启用校准。若启用校准，Arm()时会应用从EEPROM读取的校准系数；若禁用校准，Arm()时会应用k=1.0, b=0.0
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_EnableChannel()

JY9516_API int JY9516_AI_EnableChannel | ( | JY9516_DeviceHandle | hDevice,
 |  | unsigned int | chCnt,
 |  | int * | chID,
 |  | JY9516_AI_Range * | range,
 |  | JY9516_AI_Coupling * | coupling,
 |  | int * | IEPE,
 |  | int * | calEnabled
 | ) |  |

使能通道

Parameters
hDevice | 板卡句柄
chCnt | 要使能的通道的数量
chID | 要使能的通道的物理号
range | 输入电压范围
coupling | 输入耦合方式
IEPE | 是否使能IEPE
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_GetCalibrationCoefficients()

JY9516_API int JY9516_AI_GetCalibrationCoefficients | ( | JY9516_DeviceHandle | hDevice,
 |  | int | chID,
 |  | JY9516_AI_Range | range,
 |  | JY9516_CalCoePosition | calCalSrc,
 |  | bool | isGolden,
 |  | float * | gain,
 |  | float * | offset
 | ) |  |

读取指定通道设置Gain、Offset调整系数

Parameters
hDev | 板卡句柄
chID | 通道ID, 0~15
range | 量程
calCalSrc | 校准系数读取置
isGolden | 要读取的是golden coefficients
gain | 增益调整系数（percentage of reading / 100）
offset | 失调调准系数（ percentage of range / 100）
Returns
成功：0；错误：错误码

◆ JY9516_AI_GetCalibrationData()

JY9516_API int JY9516_AI_GetCalibrationData | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_AI_Range | range,
 |  | bool | isGolden,
 |  | unsigned char * | data
 | ) |  |

获取指定量程下所有通道的未解析的校准数据。该API用于实现校准数据拷贝

Parameters
hDevice | 板卡句柄
range | 指定量程
isGolden | 要读取的是golden coefficients
data | 校准数据缓冲区，大小必须为 sizeof(float) * 2 * 16

◆ JY9516_AI_GetCalibrationInfo()

JY9516_API int JY9516_AI_GetCalibrationInfo | ( | JY9516_DeviceHandle | hDevice,
 |  | bool | isGolden,
 |  | short * | timestamp,
 |  | double * | temperature,
 |  | short * | coefficientsSizeInBytes,
 |  | unsigned short * | coefficientsCRC16,
 |  | float * | sampleRate
 | ) |  |

从EEPROM读AI校准信息

Parameters
hDevice | 板卡句柄
isGolden | 要读取的是golden coefficients
timestamp | 时间戳
temperature | 温度
coefficientsSizeInBytes | 系数长度
coefficientsCRC16 | CRC16
sampleRate | 采样率
Returns
成功：0 , 失败：!=0

◆ JY9516_AI_GetCurrentClkFreq()

JY9516_API int JY9516_AI_GetCurrentClkFreq | ( | JY9516_DeviceHandle | hDevice,
 |  | double * | mclkFreq,
 |  | double * | fMod,
 |  | double * | dclkFreq
 | ) |  |

获取当前状态下的各个时钟的频率，至少Arm()一次后才有效

Parameters
hDevice | 板卡句柄
mclkFreq | 提供给ADC的时钟MCLK（即PLL输出的时钟）的频率
fMod | adc调制器频率
dclkFreq | ADC提供的数据时钟DCLK的频率
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_GetFilterState()

JY9516_API int JY9516_AI_GetFilterState | ( | JY9516_DeviceHandle | hDevice,
 |  | bool * | filterSettled
 | ) |  |

获取滤波器建立标志。每当ADC被复位后，该标志会被复位为0，直到滤波器重新建立。

Parameters
hDev | 板卡句柄
isSettled | 滤波器是否已建立
Returns
成功：0；错误：错误码

◆ JY9516_AI_ParseSampleRate()

JY9516_API int JY9516_AI_ParseSampleRate | ( | double | sampleRate,
 |  | JY9516_AI_FilterMode | filterMode,
 |  | double * | mclkFreq,
 |  | double * | fMod,
 |  | double * | dclkFreq,
 |  | int * | adcDec,
 |  | int * | fpgaDec,
 |  | int * | filterType,
 |  | bool * | fpgaSinc5Enabled,
 |  | double * | groupDelay
 | ) |  |

获取指定采样率下的各个时钟的频率

Parameters
sampleRate | 板卡句柄
filterMode | 滤波器模式
mclkFreq | 提供给ADC的时钟MCLK（即PLL输出的时钟）的频率
fMod | adc调制器频率
dclkFreq | ADC提供的数据时钟DCLK的频率
adcDec | ADC内部对数据的降采样倍率
fpgaDec | FPGA提供的降采样倍率
filterType | ADC所使用的滤波器类型。0：Wideband；1：Sinc5
fpgaSinc5Enabled | FPGA是否使能了Sinc5滤波器
groupDelay | 总的群延迟，单位Sa
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_ReadData()

JY9516_API int JY9516_AI_ReadData | ( | JY9516_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

读取数据

Parameters
hDevice | 板卡句柄
dataBuffer | 返回采集数据的工程值（电压，单位V）
dataLength | 要读取的数据长度
timeout | 读取数据超时时间(ms)，为-1时永不超时
actualReadLength | 返回实际读取到的数据长度
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_ReadRawData()

JY9516_API int JY9516_AI_ReadRawData | ( | JY9516_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength
 | ) |  |

读取数据(原始值)

Parameters
hDevice | 板卡句柄
dataBuffer | 返回采集数据原始值
dataLength | 要读取的数据长度
timeout | 读取数据超时时间(ms)，为-1时永不超时
actualReadLength | 返回实际读取到的数据长度
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_ReadSingleHeader()

JY9516_API int JY9516_AI_ReadSingleHeader | ( | JY9516_DeviceHandle | hDevice,
 |  | int * | headerBuffer
 | ) |  |

获取所有已使能通道的转换输出标头（非缓冲式读取）

Parameters
hDevice | 板卡句柄
header | 返回标头数组。bit[3:0]: 通道ID；bit4: 滤波器饱和；bit5: 滤波器类型（0-宽带滤波器，1-sinc5滤波器）；bit6：重复数据；bit7：滤波器未建立；bit8：芯片错误。
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_ReadSinglePoint()

JY9516_API int JY9516_AI_ReadSinglePoint | ( | JY9516_DeviceHandle | hDevice,
 |  | double * | dataBuffer
 | ) |  |

获取所有已使能通道的转换输出数据（非缓冲式读取）

Parameters
hDevice | 板卡句柄
dataBuffer | 返回转换输出数据（电压，单位V）
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SendSoftwareTrigger()

JY9516_API int JY9516_AI_SendSoftwareTrigger | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_AI_TriggerSel | triggerSel
 | ) |  |

发送软件触发

Parameters
hDevice | 板卡句柄
triggerSel | 选择要作用的触发
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetAdvanceTriggerType()

JY9516_API int JY9516_AI_SetAdvanceTriggerType | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_AI_TriggerType | triggerType
 | ) |  |

设置AdvanceTrigger的触发模式

Parameters
hDevice 板卡句柄
availableSamplsCount 开始触发的工作模式(Immediate/Digital/Analog/Software)/param>
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetAnalogTrigger()

JY9516_API int JY9516_AI_SetAnalogTrigger | ( | JY9516_DeviceHandle | hDevice,
 |  | unsigned int | triggerSource,
 |  | JY9516_AnalogTriggerCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

设置模拟触发

Parameters
hDevice | 板卡句柄
triggerSource | 模拟触发源通道选择
triggerCondition | 数字触发源触发条件选择
highThreshold | 高阈值电压(V)
lowThreshold | 低阈值电压(V)
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetBesselComp()

JY9516_API int JY9516_AI_SetBesselComp | ( | JY9516_DeviceHandle | hDevice,
 |  | bool | enable
 | ) |  |

设置Bessel滤波器造成的通带衰减的补偿

Parameters
hDevice | 板卡句柄
enable | 是否使能。默认使能。

◆ JY9516_AI_SetCalibrationCoefficients()

JY9516_API int JY9516_AI_SetCalibrationCoefficients | ( | JY9516_DeviceHandle | hDevice,
 |  | int | chID,
 |  | JY9516_AI_Range | range,
 |  | JY9516_CalCoePosition | calCoeDest,
 |  | bool | isGolden,
 |  | float | gain,
 |  | float | offset
 | ) |  |

为指定通道指定量程设置Gain、Offset调整系数

Parameters
hDev | 板卡句柄
chID | 通道ID, 0~15
range | 量程
calCoeDest | 校准系数写入位置
isGolden | 要写入的是golden coefficients
gain | 增益调整系数（percentage of reading / 100）
offset | 失调调准系数（ percentage of range / 100）
Returns
成功：0；错误：错误码

◆ JY9516_AI_SetCalibrationData()

JY9516_API int JY9516_AI_SetCalibrationData | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_AI_Range | range,
 |  | bool | isGolden,
 |  | unsigned char * | data
 | ) |  |

写入指定量程下所有通道的未解析的校准数据。该API用于实现校准数据拷贝

Parameters
hDevice | 板卡句柄
range | 指定量程
isGolden | 要写入的是golden coefficients
data | 包含校准数据的缓冲区，大小必须为 sizeof(float) * 2 * 16，数据排序为按物理通道号依次排序k、b

◆ JY9516_AI_SetCalibrationInfo()

JY9516_API int JY9516_AI_SetCalibrationInfo | ( | JY9516_DeviceHandle | hDevice,
 |  | bool | isGolden,
 |  | short | timestamp,
 |  | double | temperature,
 |  | short | coefficientsSizeInBytes,
 |  | unsigned short | coefficientsCRC16,
 |  | float | sampleRate
 | ) |  |

写AI校准信息到EEPROM

Parameters
hDevice | 板卡句柄
isGolden | 要写入的是golden coefficients
timestamp | 时间戳
temperature | 温度
coefficientsSizeInBytes | 系数长度
coefficientsCRC16 | CRC16
sampleRate | 采样率
Returns
成功：0 , 失败：!=0

◆ JY9516_AI_SetDigitalAdvanceTrigger()

JY9516_API int JY9516_AI_SetDigitalAdvanceTrigger | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_IOTerminal | triggerSource,
 |  | JY9516_DigitalTriggerEdge | triggerEdge
 | ) |  |

设置AdvanceTrigger的数字触发源

Parameters
hDevice | 板卡句柄
triggerSource | 数字触发源通道选择
triggerEdge | 数字触发源触发条件选择
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetDigitalReferenceTrigger()

JY9516_API int JY9516_AI_SetDigitalReferenceTrigger | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_IOTerminal | triggerSource,
 |  | JY9516_DigitalTriggerEdge | triggerEdge
 | ) |  |

设置ReferenceTrigger的数字触发源

Parameters
hDevice | 板卡句柄
triggerSource | 数字触发源通道选择
triggerEdge | 数字触发源触发条件选择
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetDigitalStartTrigger()

JY9516_API int JY9516_AI_SetDigitalStartTrigger | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_IOTerminal | triggerSource,
 |  | JY9516_DigitalTriggerEdge | triggerEdge
 | ) |  |

设置StartTrigger的数字触发源

Parameters
hDevice | 板卡句柄
triggerSource | 数字触发源通道选择
triggerEdge | 数字触发源触发条件选择
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetFilterMode()

JY9516_API int JY9516_AI_SetFilterMode | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_AI_FilterMode | filterMode
 | ) |  |

设置调制模式

Parameters
hDevice | 板卡句柄
filterMode | 滤波器模式

◆ JY9516_AI_SetPLLSyncDelay()

JY9516_API int JY9516_AI_SetPLLSyncDelay | ( | JY9516_DeviceHandle | hDevice,
 |  | int | tapCnt
 | ) |  |

设置PLL Sync信号的输出延迟，用于精准调节PLL Sync与PLL OSCin的时序关系。

Parameters
hDevice | 板卡句柄
tapCnt | 延迟量，有效范围为0-31，每tap为78ps。
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetPreTriggerSamples()

JY9516_API int JY9516_AI_SetPreTriggerSamples | ( | JY9516_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

设置预触发点数

Parameters
hDevice | 板卡句柄
preTriggerSamples | 预触发点数
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetRefClkSrc()

JY9516_API int JY9516_AI_SetRefClkSrc | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_RefClockSource | refClkSrc
 | ) |  |

设置参考时钟源

Parameters
hDevice | 板卡句柄
refClkSrc | 参考时钟源
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetReferenceTriggerType()

JY9516_API int JY9516_AI_SetReferenceTriggerType | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_AI_TriggerType | triggerType
 | ) |  |

设置StartTigger的触发模式

Parameters
hDevice | 板卡句柄
triggerType | 参考触发的工作模式(Immediate/Digital/Analog/Software)
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetReTriggerCount()

JY9516_API int JY9516_AI_SetReTriggerCount | ( | JY9516_DeviceHandle | hDevice,
 |  | int | reTriggerCount
 | ) |  |

设置重触发次数

Parameters
hDevice | 板卡句柄
reTriggerCount | 重触发次数
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetSampleMode()

JY9516_API int JY9516_AI_SetSampleMode | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_AI_SampleMode | mode
 | ) |  |

设置采样模式

Parameters
hDevice | 板卡句柄
mode | 采样模式
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetSampleRate()

JY9516_API int JY9516_AI_SetSampleRate | ( | JY9516_DeviceHandle | hDevice,
 |  | double | sampleRate
 | ) |  |

设置采样率

Parameters
hDevice | 板卡句柄
sampleRate | 要设置的采样率
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetSamplesToAcquire()

JY9516_API int JY9516_AI_SetSamplesToAcquire | ( | JY9516_DeviceHandle | hDevice,
 |  | unsigned int | samplesToAcquire
 | ) |  |

设置待采样数

Parameters
hDevice | 板卡句柄
samplesToAcquire | 待采样数，即每个通道上要采集的样点数
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_SetStartTriggerType()

JY9516_API int JY9516_AI_SetStartTriggerType | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_AI_TriggerType | triggerType
 | ) |  |

设置StartTigger的触发模式

Parameters
hDevice | 板卡句柄
triggerType | 开始触发的工作模式(Immediate/Digital/Analog/Software)
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_Start()

JY9516_API int JY9516_AI_Start ( JY9516_DeviceHandle hDevice )

开始任务

Parameters
hDevice 板卡句柄
Returns
成功：0 , 失败：!=0

◆ JY9516_AI_Stop()

JY9516_API int JY9516_AI_Stop ( JY9516_DeviceHandle hDevice )

停止采集

Parameters
hDevice 板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_Sync()

JY9516_API int JY9516_AI_Sync ( JY9516_DeviceHandle hDevice )

启动同步。当同步模式为Sole时，立即同步PLL和ADC，不输出同步请求；当同步模式为Master时，立即同步PLL和ADC，并输出同步请求；当同步模式为Slave时，等待同步请求到达后同步PLL和ADC。应先开启Slave的同步流程，再开启Master的同步流程。

Parameters
hDevice 板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_WaitUntilDone()

JY9516_API int JY9516_AI_WaitUntilDone | ( | JY9516_DeviceHandle | hDevice,
 |  | int | timeout,
 |  | bool * | done
 | ) |  |

检查有限点采集是否已完成

Parameters
hDevice | 板卡句柄
timeout | 超时时间(ms)，为-1时永不超时
done | 返回有限点采集是否已完成(true/false)
Returns
0：无错误；其它：发生错误

◆ JY9516_AI_WaitUntilFilterSettled()

JY9516_API int JY9516_AI_WaitUntilFilterSettled | ( | JY9516_DeviceHandle | hDevice,
 |  | int | timeout,
 |  | bool * | filterSettled
 | ) |  |

等待直到滤波器完成建立

Parameters
hDevice | 板卡句柄
timeout | 超时时间(ms)，为-1时永不超时
done | 返回滤波器是否已建立(true/false)
Returns
0：无错误；其它：发生错误

◆ JY9516_CalCRC16()

JY9516_API int JY9516_CalCRC16 | ( | char * | data,
 |  | unsigned int | dataLen,
 |  | unsigned short * | CRC16
 | ) |  |

计算CRC16

Parameters
hDevice | 板卡句柄
data | 数据
dataLen | 数据长度
CRC16 | 返回CRC16
Returns
成功：0 , 失败：!=0

◆ JY9516_Close()

JY9516_API int JY9516_Close ( JY9516_DeviceHandle hDevice )

关闭设备，释放句柄

Parameters
cardName | 板卡名
hDevice | 返回板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516_DAC_ClearCalibrationCoefficientsValidFlag()

JY9516_API int JY9516_DAC_ClearCalibrationCoefficientsValidFlag ( JY9516_DeviceHandle hDevice )

清除DAC校准系数有效标记，使下次开始任务时总是会从EEPROM更新校准系数

Parameters
hDevice 板卡句柄
Returns
成功：0 , 失败：!=0

◆ JY9516_DAC_GetCalibrationCoefficients()

JY9516_API int JY9516_DAC_GetCalibrationCoefficients | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_CalCoePosition | calCalSrc,
 |  | float * | gain,
 |  | float * | offset
 | ) |  |

获取DAC的Gain、Offset调整系数

Parameters
hDev | 板卡句柄
calCoeDest | 校准系数写入位置
gain | 增益调整系数（percentage of reading / 100）
offset | 失调调准系数（ percentage of range / 100），range固定为10V
Returns
成功：0；错误：错误码

◆ JY9516_DAC_GetCalibrationInfo()

JY9516_API int JY9516_DAC_GetCalibrationInfo | ( | JY9516_DeviceHandle | hDevice,
 |  | short * | timestamp,
 |  | double * | temperature,
 |  | short * | coefficientsSizeInBytes,
 |  | unsigned short * | coefficientsCRC16
 | ) |  |

从EEPROM读DAC校准信息

Parameters
hDevice | 板卡句柄
timestamp | 要被写入数据的通道
temperature | 通道数
coefficientsSizeInBytes | 要写入的数据的数组
coefficientsCRC16 | 要写入的数据的数组
Returns
成功：0 , 失败：!=0

◆ JY9516_DAC_IssueTemperatureRecalibration()

JY9516_API int JY9516_DAC_IssueTemperatureRecalibration | ( | JY9516_DeviceHandle | hDevice,
 |  | int | timeout,
 |  | bool * | done
 | ) |  |

启动DAC温漂校准流程

Parameters
hDev | 板卡句柄
timeout | 超时时间
done | 是否完成
Returns
正确：0，错误：错误码

◆ JY9516_DAC_SetCalibrationCoefficients()

JY9516_API int JY9516_DAC_SetCalibrationCoefficients | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_CalCoePosition | calCoeDest,
 |  | float | gain,
 |  | float | offset
 | ) |  |

为DAC设置Gain、Offset调整系数

Parameters
hDev | 板卡句柄
calCoeDest | 校准系数写入位置
gain | 增益调整系数（percentage of reading / 100）
offset | 失调调准系数（ percentage of range / 100），range固定为10V
Returns
成功：0；错误：错误码

◆ JY9516_DAC_SetCalibrationInfo()

JY9516_API int JY9516_DAC_SetCalibrationInfo | ( | JY9516_DeviceHandle | hDevice,
 |  | short | timestamp,
 |  | double | temperature,
 |  | short | coefficientsSizeInBytes,
 |  | unsigned short | coefficientsCRC16
 | ) |  |

写DAC校准信息到EEPROM

Parameters
hDevice | 板卡句柄
timestamp | 要被写入数据的通道
temperature | 通道数
coefficientsSizeInBytes | 要写入的数据的数组
coefficientsCRC16 | 要写入的数据的数组
Returns
成功：0 , 失败：!=0

◆ JY9516_DAC_SetOutputVoltage()

JY9516_API int JY9516_DAC_SetOutputVoltage | ( | JY9516_DeviceHandle | hDevice,
 |  | double | voltage
 | ) |  |

获取DAC电源状态(2022.11.01 实际调试情况发现该寄存器读取回来的值不能正确反应Power状态，即使PowerDown了也显示为PowerUp)

Parameters
hDevice | 板卡句柄
powerDown | DAC是否处于关闭状态
Returns
0：无错误；其它：发生错误

设置DAC输出电压

Parameters
hDevice | 板卡句柄
voltage | 输出电压（V）
calibrationEnabled | 是否使能校准
Returns
0：无错误；其它：发生错误

◆ JY9516_DAC_SetPowerDown()

JY9516_API int JY9516_DAC_SetPowerDown | ( | JY9516_DeviceHandle | hDevice,
 |  | bool | powerDown
 | ) |  |

设置DAC电源状态

Parameters
hDevice | 板卡句柄
powerDown | 是否要关闭DAC
Returns
0：无错误；其它：发生错误

◆ JY9516_DisconnectSignalToExport()

JY9516_API int JY9516_DisconnectSignalToExport | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_IOTerminal | destination
 | ) |  |

断开指定端口与内部信号的连接，复位到低电平

Parameters
hDevice | 板卡句柄
destination | 导出端口
Returns
0：无错误；其它：发生错误

◆ JY9516_GetBoardTemperature()

JY9516_API int JY9516_GetBoardTemperature | ( | JY9516_DeviceHandle | hDevice,
 |  | double * | temperature
 | ) |  |

获取板卡温度

Parameters
hDevice | 板卡句柄
temperature | 返回值：板卡温度(℃)
Returns
0：无错误；其它：发生错误

◆ JY9516_GetDeviceInfo()

JY9516_API int JY9516_GetDeviceInfo | ( | JY9516_DeviceHandle | hDevice,
 |  | unsigned char * | info
 | ) |  |

获取设备信息

Parameters
hDevice | 板卡句柄
deviceID | 板卡ID
Returns
0：无错误；其它：发生错误

◆ JY9516_Init()

JY9516_API int JY9516_Init ( JY9516_DeviceHandle hDevice )

初始化

Parameters
hDevice 板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516_Open()

JY9516_API int JY9516_Open | ( | int | slotNumber,
 |  | JY9516_DeviceHandle * | hDevice
 | ) |  |

打开板卡

Parameters
slotNumber | 板卡号
hDevice | 返回板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516_OpenByName()

JY9516_API int JY9516_OpenByName | ( | const char * | cardName,
 |  | JY9516_DeviceHandle * | hDevice
 | ) |  |

以别名打开板卡

Parameters
cardName | 板卡名
hDevice | 返回板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516_ReadAD7768Reg()

JY9516_API int JY9516_ReadAD7768Reg | ( | JY9516_DeviceHandle | hDevice,
 |  | int | chipID,
 |  | int | regAddr,
 |  | int * | value
 | ) |  |

直接从AD7768指定地址读出数据

Parameters
hDevice | 板卡句柄
chipID | 芯片ID
regAddr | 寄存器地址
value | 值
Returns
正确：0，错误：错误码

◆ JY9516_ResetAD7768()

JY9516_API int JY9516_ResetAD7768 ( JY9516_DeviceHandle hDevice )

产生一个硬件复位信号，复位两片AD7768

Parameters
hDevice 板卡句柄

◆ JY9516_RouteSignalToExport()

JY9516_API int JY9516_RouteSignalToExport | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_IOTerminal | destination,
 |  | JY9516_ExportSource | source
 | ) |  |

导出内部信号到指定端口

Parameters
hDevice | 板卡句柄
destination | 导出端口
source | 要导出的信号
Returns
0：无错误；其它：发生错误

◆ JY9516_SetAD7768FChop()

JY9516_API int JY9516_SetAD7768FChop | ( | JY9516_DeviceHandle | hDevice,
 |  | JY9516_ADC_fChop_Div | fchopDiv
 | ) |  |

设置ADC调制器斩波频率

Parameters
hDevice 板卡句柄
fchopDiv

◆ JY9516_WriteAD7768Reg()

JY9516_API int JY9516_WriteAD7768Reg | ( | JY9516_DeviceHandle | hDevice,
 |  | int | chipID,
 |  | int | regAddr,
 |  | int | value
 | ) |  |

直接向AD7768指定地址写入数据

Parameters
hDevice | 板卡句柄
chipID | 芯片ID
regAddr | 寄存器地址
value | 值
Returns
正确：0，错误：错误码


9516 C++ Programming Manual: D:/9516 Directory Reference

  • D:
  • 9516
9516 Directory Reference

Directories

directory Cpp


9516 C++ Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 9516


9516 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 9516
▼ Cpp
JY9516.h


9516 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- j -

  • JY9516_ADC_fChop_32 : JY9516.h
  • JY9516_ADC_fChop_8 : JY9516.h
  • JY9516_ADC_fChop_Div : JY9516.h
  • JY9516_AI_Analog : JY9516.h
  • JY9516_AI_CheckBufferStatus() : JY9516.h
  • JY9516_AI_CheckRxStatus() : JY9516.h
  • JY9516_AI_CheckSyncStatus() : JY9516.h
  • JY9516_AI_ClearCalibrationCoefficientsValidFlag() : JY9516.h
  • JY9516_AI_Commit() : JY9516.h
  • JY9516_AI_ConfigSync() : JY9516.h
  • JY9516_AI_Continuous : JY9516.h
  • JY9516_AI_Coupling : JY9516.h
  • JY9516_AI_DetectIEPEConnection() : JY9516.h
  • JY9516_AI_Digital : JY9516.h
  • JY9516_AI_EnableCalibration() : JY9516.h
  • JY9516_AI_EnableChannel() : JY9516.h
  • JY9516_AI_FilterMode : JY9516.h
  • JY9516_AI_FilterMode_Normal : JY9516.h
  • JY9516_AI_FilterMode_WideBandwidth : JY9516.h
  • JY9516_AI_Finite : JY9516.h
  • JY9516_AI_GetCalibrationCoefficients() : JY9516.h
  • JY9516_AI_GetCalibrationData() : JY9516.h
  • JY9516_AI_GetCalibrationInfo() : JY9516.h
  • JY9516_AI_GetCurrentClkFreq() : JY9516.h
  • JY9516_AI_GetFilterState() : JY9516.h
  • JY9516_AI_Immediately : JY9516.h
  • JY9516_AI_ParseSampleRate() : JY9516.h
  • JY9516_AI_Range : JY9516.h
  • JY9516_AI_ReadData() : JY9516.h
  • JY9516_AI_ReadRawData() : JY9516.h
  • JY9516_AI_ReadSingleHeader() : JY9516.h
  • JY9516_AI_ReadSinglePoint() : JY9516.h
  • JY9516_AI_SampleMode : JY9516.h
  • JY9516_AI_SendSoftwareTrigger() : JY9516.h
  • JY9516_AI_SetAdvanceTriggerType() : JY9516.h
  • JY9516_AI_SetAnalogTrigger() : JY9516.h
  • JY9516_AI_SetBesselComp() : JY9516.h
  • JY9516_AI_SetCalibrationCoefficients() : JY9516.h
  • JY9516_AI_SetCalibrationData() : JY9516.h
  • JY9516_AI_SetCalibrationInfo() : JY9516.h
  • JY9516_AI_SetDigitalAdvanceTrigger() : JY9516.h
  • JY9516_AI_SetDigitalReferenceTrigger() : JY9516.h
  • JY9516_AI_SetDigitalStartTrigger() : JY9516.h
  • JY9516_AI_SetFilterMode() : JY9516.h
  • JY9516_AI_SetPLLSyncDelay() : JY9516.h
  • JY9516_AI_SetPreTriggerSamples() : JY9516.h
  • JY9516_AI_SetRefClkSrc() : JY9516.h
  • JY9516_AI_SetReferenceTriggerType() : JY9516.h
  • JY9516_AI_SetReTriggerCount() : JY9516.h
  • JY9516_AI_SetSampleMode() : JY9516.h
  • JY9516_AI_SetSampleRate() : JY9516.h
  • JY9516_AI_SetSamplesToAcquire() : JY9516.h
  • JY9516_AI_SetStartTriggerType() : JY9516.h
  • JY9516_AI_Single : JY9516.h
  • JY9516_AI_Software : JY9516.h
  • JY9516_AI_Start() : JY9516.h
  • JY9516_AI_Stop() : JY9516.h
  • JY9516_AI_Sync() : JY9516.h
  • JY9516_AI_Trigger_Advance : JY9516.h
  • JY9516_AI_Trigger_Reference : JY9516.h
  • JY9516_AI_Trigger_Start : JY9516.h
  • JY9516_AI_TriggerSel : JY9516.h
  • JY9516_AI_TriggerType : JY9516.h
  • JY9516_AI_WaitUntilDone() : JY9516.h
  • JY9516_AI_WaitUntilFilterSettled() : JY9516.h
  • JY9516_AnalogTriggerCondition : JY9516.h
  • JY9516_CalCoePosition : JY9516.h
  • JY9516_CalCoePosition_EEPROM : JY9516.h
  • JY9516_CalCoePosition_Handle : JY9516.h
  • JY9516_CalCRC16() : JY9516.h
  • JY9516_Close() : JY9516.h
  • JY9516_Coupling_AC : JY9516.h
  • JY9516_Coupling_DC : JY9516.h
  • JY9516_DAC_ClearCalibrationCoefficientsValidFlag() : JY9516.h
  • JY9516_DAC_GetCalibrationCoefficients() : JY9516.h
  • JY9516_DAC_GetCalibrationInfo() : JY9516.h
  • JY9516_DAC_IssueTemperatureRecalibration() : JY9516.h
  • JY9516_DAC_SetCalibrationCoefficients() : JY9516.h
  • JY9516_DAC_SetCalibrationInfo() : JY9516.h
  • JY9516_DAC_SetOutputVoltage() : JY9516.h
  • JY9516_DAC_SetPowerDown() : JY9516.h
  • JY9516_DeviceHandle : JY9516.h
  • JY9516_DigitalTriggerEdge : JY9516.h
  • JY9516_DisconnectSignalToExport() : JY9516.h
  • JY9516_EnteringWindow : JY9516.h
  • JY9516_EXPORT_ADC_SYNC : JY9516.h
  • JY9516_EXPORT_DCLK : JY9516.h
  • JY9516_EXPORT_MCLK : JY9516.h
  • JY9516_EXPORT_PLL_SYNC : JY9516.h
  • JY9516_EXPORT_RX_ADV_TRIG : JY9516.h
  • JY9516_EXPORT_RX_END_OF_RECORD : JY9516.h
  • JY9516_EXPORT_RX_ENGINE_END : JY9516.h
  • JY9516_EXPORT_RX_READY_FOR_ADV_TRIG : JY9516.h
  • JY9516_EXPORT_RX_READY_FOR_REF_TRIG : JY9516.h
  • JY9516_EXPORT_RX_READY_FOR_START_TRIG : JY9516.h
  • JY9516_EXPORT_RX_REF_TRIG : JY9516.h
  • JY9516_EXPORT_RX_START_TRIG : JY9516.h
  • JY9516_EXPORT_SAMPLE_CLOCK : JY9516.h
  • JY9516_EXPORT_SYNC_ENABLE : JY9516.h
  • JY9516_ExportSource : JY9516.h
  • JY9516_External_Trigger : JY9516.h
  • JY9516_Falling : JY9516.h
  • JY9516_FallingHysteresis : JY9516.h
  • JY9516_GetBoardTemperature() : JY9516.h
  • JY9516_GetDeviceInfo() : JY9516.h
  • JY9516_IEPEConnection_Normal : JY9516.h
  • JY9516_IEPEConnection_Open : JY9516.h
  • JY9516_IEPEConnection_Short : JY9516.h
  • JY9516_IEPEConnectionStatus : JY9516.h
  • JY9516_Init() : JY9516.h
  • JY9516_IOTerminal : JY9516.h
  • JY9516_LeavingWindow : JY9516.h
  • JY9516_Onboard_10M : JY9516.h
  • JY9516_Open() : JY9516.h
  • JY9516_OpenByName() : JY9516.h
  • JY9516_PXI_Star : JY9516.h
  • JY9516_PXI_Trig_0 : JY9516.h
  • JY9516_PXI_Trig_1 : JY9516.h
  • JY9516_PXI_Trig_2 : JY9516.h
  • JY9516_PXI_Trig_3 : JY9516.h
  • JY9516_PXI_Trig_4 : JY9516.h
  • JY9516_PXI_Trig_5 : JY9516.h
  • JY9516_PXI_Trig_6 : JY9516.h
  • JY9516_PXI_Trig_7 : JY9516.h
  • JY9516_PXIe_Clk_100M : JY9516.h
  • JY9516_Range_0p3125V : JY9516.h
  • JY9516_Range_0p625V : JY9516.h
  • JY9516_Range_10V : JY9516.h
  • JY9516_Range_1p25V : JY9516.h
  • JY9516_Range_2p5V : JY9516.h
  • JY9516_Range_5V : JY9516.h
  • JY9516_ReadAD7768Reg() : JY9516.h
  • JY9516_RefClockSource : JY9516.h
  • JY9516_ResetAD7768() : JY9516.h
  • JY9516_Rising : JY9516.h
  • JY9516_RisingHysteresis : JY9516.h
  • JY9516_RouteSignalToExport() : JY9516.h
  • JY9516_SetAD7768FChop() : JY9516.h
  • JY9516_SyncMode : JY9516.h
  • JY9516_SyncMode_Master : JY9516.h
  • JY9516_SyncMode_Slave : JY9516.h
  • JY9516_SyncMode_Sole : JY9516.h
  • JY9516_WriteAD7768Reg() : JY9516.h


9516 C++ Programming Manual: File Members

  • JY9516_ADC_fChop_Div : JY9516.h
  • JY9516_AI_Coupling : JY9516.h
  • JY9516_AI_FilterMode : JY9516.h
  • JY9516_AI_Range : JY9516.h
  • JY9516_AI_SampleMode : JY9516.h
  • JY9516_AI_TriggerSel : JY9516.h
  • JY9516_AI_TriggerType : JY9516.h
  • JY9516_AnalogTriggerCondition : JY9516.h
  • JY9516_CalCoePosition : JY9516.h
  • JY9516_DigitalTriggerEdge : JY9516.h
  • JY9516_ExportSource : JY9516.h
  • JY9516_IEPEConnectionStatus : JY9516.h
  • JY9516_IOTerminal : JY9516.h
  • JY9516_RefClockSource : JY9516.h
  • JY9516_SyncMode : JY9516.h


9516 C++ Programming Manual: File Members

- j -

  • JY9516_ADC_fChop_32 : JY9516.h
  • JY9516_ADC_fChop_8 : JY9516.h
  • JY9516_AI_Analog : JY9516.h
  • JY9516_AI_Continuous : JY9516.h
  • JY9516_AI_Digital : JY9516.h
  • JY9516_AI_FilterMode_Normal : JY9516.h
  • JY9516_AI_FilterMode_WideBandwidth : JY9516.h
  • JY9516_AI_Finite : JY9516.h
  • JY9516_AI_Immediately : JY9516.h
  • JY9516_AI_Single : JY9516.h
  • JY9516_AI_Software : JY9516.h
  • JY9516_AI_Trigger_Advance : JY9516.h
  • JY9516_AI_Trigger_Reference : JY9516.h
  • JY9516_AI_Trigger_Start : JY9516.h
  • JY9516_CalCoePosition_EEPROM : JY9516.h
  • JY9516_CalCoePosition_Handle : JY9516.h
  • JY9516_Coupling_AC : JY9516.h
  • JY9516_Coupling_DC : JY9516.h
  • JY9516_EnteringWindow : JY9516.h
  • JY9516_EXPORT_ADC_SYNC : JY9516.h
  • JY9516_EXPORT_DCLK : JY9516.h
  • JY9516_EXPORT_MCLK : JY9516.h
  • JY9516_EXPORT_PLL_SYNC : JY9516.h
  • JY9516_EXPORT_RX_ADV_TRIG : JY9516.h
  • JY9516_EXPORT_RX_END_OF_RECORD : JY9516.h
  • JY9516_EXPORT_RX_ENGINE_END : JY9516.h
  • JY9516_EXPORT_RX_READY_FOR_ADV_TRIG : JY9516.h
  • JY9516_EXPORT_RX_READY_FOR_REF_TRIG : JY9516.h
  • JY9516_EXPORT_RX_READY_FOR_START_TRIG : JY9516.h
  • JY9516_EXPORT_RX_REF_TRIG : JY9516.h
  • JY9516_EXPORT_RX_START_TRIG : JY9516.h
  • JY9516_EXPORT_SAMPLE_CLOCK : JY9516.h
  • JY9516_EXPORT_SYNC_ENABLE : JY9516.h
  • JY9516_External_Trigger : JY9516.h
  • JY9516_Falling : JY9516.h
  • JY9516_FallingHysteresis : JY9516.h
  • JY9516_IEPEConnection_Normal : JY9516.h
  • JY9516_IEPEConnection_Open : JY9516.h
  • JY9516_IEPEConnection_Short : JY9516.h
  • JY9516_LeavingWindow : JY9516.h
  • JY9516_Onboard_10M : JY9516.h
  • JY9516_PXI_Star : JY9516.h
  • JY9516_PXI_Trig_0 : JY9516.h
  • JY9516_PXI_Trig_1 : JY9516.h
  • JY9516_PXI_Trig_2 : JY9516.h
  • JY9516_PXI_Trig_3 : JY9516.h
  • JY9516_PXI_Trig_4 : JY9516.h
  • JY9516_PXI_Trig_5 : JY9516.h
  • JY9516_PXI_Trig_6 : JY9516.h
  • JY9516_PXI_Trig_7 : JY9516.h
  • JY9516_PXIe_Clk_100M : JY9516.h
  • JY9516_Range_0p3125V : JY9516.h
  • JY9516_Range_0p625V : JY9516.h
  • JY9516_Range_10V : JY9516.h
  • JY9516_Range_1p25V : JY9516.h
  • JY9516_Range_2p5V : JY9516.h
  • JY9516_Range_5V : JY9516.h
  • JY9516_Rising : JY9516.h
  • JY9516_RisingHysteresis : JY9516.h
  • JY9516_SyncMode_Master : JY9516.h
  • JY9516_SyncMode_Slave : JY9516.h
  • JY9516_SyncMode_Sole : JY9516.h


9516 C++ Programming Manual: File Members

- j -

  • JY9516_AI_CheckBufferStatus() : JY9516.h
  • JY9516_AI_CheckRxStatus() : JY9516.h
  • JY9516_AI_CheckSyncStatus() : JY9516.h
  • JY9516_AI_ClearCalibrationCoefficientsValidFlag() : JY9516.h
  • JY9516_AI_Commit() : JY9516.h
  • JY9516_AI_ConfigSync() : JY9516.h
  • JY9516_AI_DetectIEPEConnection() : JY9516.h
  • JY9516_AI_EnableCalibration() : JY9516.h
  • JY9516_AI_EnableChannel() : JY9516.h
  • JY9516_AI_GetCalibrationCoefficients() : JY9516.h
  • JY9516_AI_GetCalibrationData() : JY9516.h
  • JY9516_AI_GetCalibrationInfo() : JY9516.h
  • JY9516_AI_GetCurrentClkFreq() : JY9516.h
  • JY9516_AI_GetFilterState() : JY9516.h
  • JY9516_AI_ParseSampleRate() : JY9516.h
  • JY9516_AI_ReadData() : JY9516.h
  • JY9516_AI_ReadRawData() : JY9516.h
  • JY9516_AI_ReadSingleHeader() : JY9516.h
  • JY9516_AI_ReadSinglePoint() : JY9516.h
  • JY9516_AI_SendSoftwareTrigger() : JY9516.h
  • JY9516_AI_SetAdvanceTriggerType() : JY9516.h
  • JY9516_AI_SetAnalogTrigger() : JY9516.h
  • JY9516_AI_SetBesselComp() : JY9516.h
  • JY9516_AI_SetCalibrationCoefficients() : JY9516.h
  • JY9516_AI_SetCalibrationData() : JY9516.h
  • JY9516_AI_SetCalibrationInfo() : JY9516.h
  • JY9516_AI_SetDigitalAdvanceTrigger() : JY9516.h
  • JY9516_AI_SetDigitalReferenceTrigger() : JY9516.h
  • JY9516_AI_SetDigitalStartTrigger() : JY9516.h
  • JY9516_AI_SetFilterMode() : JY9516.h
  • JY9516_AI_SetPLLSyncDelay() : JY9516.h
  • JY9516_AI_SetPreTriggerSamples() : JY9516.h
  • JY9516_AI_SetRefClkSrc() : JY9516.h
  • JY9516_AI_SetReferenceTriggerType() : JY9516.h
  • JY9516_AI_SetReTriggerCount() : JY9516.h
  • JY9516_AI_SetSampleMode() : JY9516.h
  • JY9516_AI_SetSampleRate() : JY9516.h
  • JY9516_AI_SetSamplesToAcquire() : JY9516.h
  • JY9516_AI_SetStartTriggerType() : JY9516.h
  • JY9516_AI_Start() : JY9516.h
  • JY9516_AI_Stop() : JY9516.h
  • JY9516_AI_Sync() : JY9516.h
  • JY9516_AI_WaitUntilDone() : JY9516.h
  • JY9516_AI_WaitUntilFilterSettled() : JY9516.h
  • JY9516_CalCRC16() : JY9516.h
  • JY9516_Close() : JY9516.h
  • JY9516_DAC_ClearCalibrationCoefficientsValidFlag() : JY9516.h
  • JY9516_DAC_GetCalibrationCoefficients() : JY9516.h
  • JY9516_DAC_GetCalibrationInfo() : JY9516.h
  • JY9516_DAC_IssueTemperatureRecalibration() : JY9516.h
  • JY9516_DAC_SetCalibrationCoefficients() : JY9516.h
  • JY9516_DAC_SetCalibrationInfo() : JY9516.h
  • JY9516_DAC_SetOutputVoltage() : JY9516.h
  • JY9516_DAC_SetPowerDown() : JY9516.h
  • JY9516_DisconnectSignalToExport() : JY9516.h
  • JY9516_GetBoardTemperature() : JY9516.h
  • JY9516_GetDeviceInfo() : JY9516.h
  • JY9516_Init() : JY9516.h
  • JY9516_Open() : JY9516.h
  • JY9516_OpenByName() : JY9516.h
  • JY9516_ReadAD7768Reg() : JY9516.h
  • JY9516_ResetAD7768() : JY9516.h
  • JY9516_RouteSignalToExport() : JY9516.h
  • JY9516_SetAD7768FChop() : JY9516.h
  • JY9516_WriteAD7768Reg() : JY9516.h


9516 C++ Programming Manual: File Members

  • JY9516_DeviceHandle : JY9516.h


9516 C++ Programming Manual: Main Page

9516 C++ Programming Manual Documentation